添加 Z-Blog 管理员草稿文章预览权限
网站文章 2026-09-21 08:44:14 4 0

博客吧发现z-blog有个设计很奇怪,那就是z-blog博客的草稿文章不能预览,就是是管理员也不能,打开草稿文章z-blog系统会提示“错误原因:该文章不存在”,其实让管理员可以预览保存为草稿的文章也不难,只需要对相关代码进行修改,就可让z-blog允许管理员预览保存为草稿后的文章了。

实现z-blog草稿文章预览:

  1. 在z-blog根目录下找到view.asp文件,并对其进行编辑
  2. 在view.asp文件中大概42、43行找到以下代码
    1
    2
    
    If Article.Level=1 Then Call ShowError(9)
    If Article.Level=2 Then

    提示:以上代码表示的意思是“如果文章的级别是1,那么就返回一个错误提示9,如果level是2,就正常执行之后的代码函数”

  3. 将以上代码替换为以下代码
    1
    
    If Article.Level<3 Then

    提示:代码表示“只要文章的级别小于3,就正常执行之后的代码函数”,也就是说草稿文章的level在小于3的范围

  4. 保存文件即可。
文章说明
本文标签:
©版权声明
本站提供的一切软件、教程和游戏辅助仅限用于娱乐和研究目的;不得将上述内容用于商业或者非法用途,否则,一切后果请用户自负。本站信息来自网络收集,版权争议与本站无关。如有侵权请邮件与我们联系处理。敬请谅解!6594404@qq.com